Failed to create assembly name object for Microsoft.UpdateServices.Administration Error = 0x80131701

I recently upgraded to ConfigMgr 2012 R2 SP1 for a client and started seeing the above error appearing in both the WCM.log file and the WSUSCTRL.log files. I could find nothing on the internet about this so eventually I bit the bullet and phoned Microsoft support. Synopsis below:

ISSUE

Failed to create assembly name object for Microsoft.UpdateServices.Administration Error = 0x80131701 in WSUSCtrl.log

In our Environment:

WSUS server is on a separate VM to the CM2012 Site Server and WSUS database (SQL 2012) is on a separate VM from both CM2012 DB and from the WSUS server.

On WSUS Server we periodically see the following message in the D:\SMS\Logs\WSUSCtrl.log:

Failed to create assembly name object for Microsoft.UpdateServices.Administration. Error = 0x80131701.

This message appears approximately every 30 minutes in the D:\SMS\Logs\WSUSCtrl.log and it also appears every hour in “D:\Program Files\Microsoft Configuration Manager\Logs\WCM.log“.

As per Logs
 WCM.Log
 7/23/2015 3:01:35 PM Checking for supported version of WSUS (min WSUS 3.0 SP2 + KB2720211 + KB2734608) SMS_WSUS_CONFIGURATION_MANAGER 4408 (0x1138)
 7/23/2015 3:01:35 PM Checking runtime v2.0.50727... SMS_WSUS_CONFIGURATION_MANAGER 4408 (0x1138)
 7/23/2015 3:01:35 PM Failed to create assembly name object for Microsoft.UpdateServices.Administration. Error = 0x80131701. SMS_WSUS_CONFIGURATION_MANAGER 4408 (0x1138)
 7/23/2015 3:01:35 PM Checking runtime v4.0.30319... SMS_WSUS_CONFIGURATION_MANAGER 4408 (0x1138)
 7/23/2015 3:01:35 PM Found supported assembly Microsoft.UpdateServices.Administration version 3.1.6001.1, file version 3.1.7600.256 SMS_WSUS_CONFIGURATION_MANAGER 4408 (0x1138)
 7/23/2015 3:01:35 PM Found supported assembly Microsoft.UpdateServices.BaseApi version 3.1.6001.1, file version 3.1.7600.256 SMS_WSUS_CONFIGURATION_MANAGER 4408 (0x1138)
 7/23/2015 3:01:35 PM Supported WSUS version found SMS_WSUS_CONFIGURATION_MANAGER 4408 (0x1138)
WSUSCTRL.Log
 7/23/2015 3:01:36 PM WSUS registry key change notification triggered. SMS_WSUS_CONTROL_MANAGER 420 (0x01A4)
 7/23/2015 3:01:36 PM Checking for supported version of WSUS (min WSUS 3.0 SP2 + KB2720211 + KB2734608) SMS_WSUS_CONTROL_MANAGER 420 (0x01A4)
 7/23/2015 3:01:36 PM Checking runtime v2.0.50727... SMS_WSUS_CONTROL_MANAGER 420 (0x01A4)
 7/23/2015 3:01:36 PM Failed to create assembly name object for Microsoft.UpdateServices.Administration. Error = 0x80131701. SMS_WSUS_CONTROL_MANAGER 420 (0x01A4)
 7/23/2015 3:01:36 PM Checking runtime v4.0.30319... SMS_WSUS_CONTROL_MANAGER 420 (0x01A4)
 7/23/2015 3:01:36 PM Found supported assembly Microsoft.UpdateServices.Administration version 3.1.6001.1, file version 3.1.7600.256 SMS_WSUS_CONTROL_MANAGER 420 (0x01A4)
 7/23/2015 3:01:36 PM Found supported assembly Microsoft.UpdateServices.BaseApi version 3.1.6001.1, file version 3.1.7600.256 SMS_WSUS_CONTROL_MANAGER 420 (0x01A4)

It used to work in CM12 R2 Issue started post upgrading to CM12 R2 SP1.

____________________________________________________________

RESOLUTION

The bad news is that unfortunately, there isn’t one. The good news is that this error doesn’t (or shouldn’t) actually affect anything and you can safely leave it logging every 30 mins to an hour (depending on the log you look at).

The official line on this is that it is a known bug in the code and will not be fixed until the next release of ConfigManger (2016), so no hotfix planned. I’m afraid we’ll just have to live with it.

 

4 thoughts on “Failed to create assembly name object for Microsoft.UpdateServices.Administration Error = 0x80131701”

  1. I have this also, but my sync log shows the following:

    Sync failed: Unknown: InvalidOperationException: There is an error in XML document (1, 458399). —> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.~~at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events). Source: Microsoft.SystemsManagementServer.SoftwareUpdatesManagement.WsusSyncAction.WSyncAction.SyncWSUS

    I havent been able to sync is weeks. Any ideas?

  2. My first thought is a communication issue with the internet or at least the specific WSUS download sites. I seem to recall having the same issue (or something very similar) when I first set up the environment for a client I’m working with presently.
    In my client’s environment there was very limited access to the internet and any machine that required it needed all the requisite sites whitelisted. Therefore, as a bare minimum, the WSUS server itself was given internet access with the sites listed in https://technet.microsoft.com/en-us/library/dd939870(WS.10).aspx whitelisted.
    However, although I was able to browse those sites from the WSUS server, I still ran into problems downloading the updates from the console. I can’t remember if I had problems synchronising too but I may have. In any case, once we had cleared up that the WSUS server itself could download and browse the sites it soon became clear that this was not possible from my ConfigMgr console (which was running on the Primary Site server). It transpired that I needed to install the ConfigMgr console on the WSUS server as the internet-related actions (downloading/maybe syncing) were based on my account and the machine I was actioning from. As only the WSUS server had access to perform these actions, the console needed operating from this box. In my case, this is what fixed the problem.
    Good luck and if it turns out this isn’t the solution (or if it is) then I’d be interested to know.

  3. I happened to discover your blog, from a Microsoft forum.
    I was having the same issue with my SCCM 2012 R2 SP1 deployment. My WSUS server runs on an seperate 2012 R2 host. I read your post, and was resigned to the point of giving up hope until next version is released, but I tried the following..
    In the SUP role configuration, I cleared the user account credentials from the ‘WSUS server connection account’ and saved the settings. I went back and tried a re-sync of the updates and it worked !
    It might help someone out there stuck in the same spot.

    1. Hi Paul

      Thanks for sharing this and glad it fixed the problem for you. I must confess I have just tried what you suggested in my setup and I am still getting the errors appearing so unfortunately it doesn’t look like this will cure the problem in every instance. Always happy to hear another solution though and hopefully it will help someone.

      Thanks,

      Simon

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.